PHP 7.2

These modules/recipes are known to be compatible with PHP 7.2, i.e. they don't require the preg_replace() function with the /e evaluation flag or create_function (or any PmWiki core function that calls it, notably Markup_e, PCCF or PPRE). Most of the recipes below also work with older PmWiki/PHP versions, see the "Prerequisites" lines on their pages.

Note that you need PmWiki version 2.2.103 or newer in order for the core to work with PHP 7.2. The recipes here-after only require PmWiki 2.2.56 or newer (unless stated otherwise on the recipe page).

See PmWiki.CustomMarkup if you need to upgrade your recipe for PHP 7.2.

See also .


Recipes compatible with PHP 7.2

PmWiki /
Troubleshooting  Advice for troubleshooting an installation, keywords: deprecated, preg_replace, crypt, blank pages, headers, .flock, upgrade, create_function